Ethernet Network Wired connection not working after fresh install

Hi. Sorry, I am very beginner to Linux OS, but I have spent 6 hours today and was not able to figure this out.

Some INFO:

  • So, I installed Kicksecure from Kicksecure ISO following this guide kicksecure . com/wiki/ISO and pressed “Install to hardrive” and installed it to my SSD. During installation my internet cable from my home router was plugged in (dunno if that matters)

What is the problem?

  • After installation finished, I booted the Kicksecure OS and everything seem to work, except my internet from my Ethernet cable.
    Note: I tried plugging a wireless card and the internet would instantly work via WIFI (after plugging i did apt-get update && upgrade). Also, on other OS on same PC, my internet through cable would work instantly. I guess that it is something with Kicksecure settings that is not working for me.

What did I do?
Well since I am a noob I was searching and trying different suggested ideas, mainly from Debian 12 (bookworm).

  • First thing i noticed I did not have /etc/network/interfaces so I tried creating that with different settings like:
auto lo
iface lo inet loopback

auto eth0
allow-hotplug eth0
iface eth0 inet dhcp

that only made my “Ethernet: wired connection 1” disappear in my nm-connection-editor. So, I removed that and started searching again.Then I read all of this forums.whonix . org/t/kicksecure-network-configuration/8985/52 and my head started to hurt. But what i understood (and maybe that is wrong) that network on Kicksecure is configured in their own unique way, not like Debian 12 /etc/network/interfaces. That realization did not help me much tho. I then noticed my connection did not have any IPv4, only IPv6. So I tried manually imagining what my IP could look like if it was static, since usually everything is DHCP. So I tried adding in my NetworkManager Applet

IP Address: 192.168.1.15
Netmask: 255.255.255.0
Gateway: 192.168.1.254
DNS servers: 192.168.1.254 (also tried 8.8.8.8)

All that did was - that instead of ping 8.8.8.8 Network unreachable I started getting

PING 8.8.8.8 (8.8.8.8) 58 (84) bytes of data.
From 192.168.1.15 icmp_seq=1 Destination Host Unreachable

Which as you can probably now tell was a progress for me. Anyway, but I am kinda stuck here and don’t know what to do. Here is how my ifconfig -a looks like:

[user ~]% ifconfig -a 
eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.15  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::de2e:a11c:5001:d8b5  prefixlen 64  scopeid 0x20<link>
        ether ac:22:0b:cc:b3:3e  txqueuelen 1000  (Ethernet)
        RX packets 71  bytes 5186 (5.0 KiB)
        RX errors 0  dropped 1  overruns 0  frame 0
        TX packets 4962  bytes 323368 (315.7 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 20  memory 0xf7300000-f7320000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 256733  bytes 553743564 (528.0 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 256733  bytes 553743564 (528.0 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Also I dont understand how to restart my network in Kicksecure, I tried:

sudo systemctl restart networking
sudo /etc/init.d/networking restart
/usr/bin/systemctl restart networking
sudo service networking restart

but nothing seems to worked, so I had to reboot my OS after yet another “new brilliant idea” that i had :slight_smile: that what hell looks like xD especially with Luks encryption -.-

Please excuse me for all this emotional spam, I am tired, frustrated, I don’t know what I am doing, but I am trying… well any tips where to keep digging would be much appreciated.

P.S @Patric, I am very sorry that you have to deal with dumb users like me :frowning:

I don’t know why this does not work out of the box for you but I can clear up some things.

There are various distinct software packages to configure networking on Linux. Some examples are ifupdown, Network Manager and systemd-networkd. “Usually” only 1 is installed by default and in use.

In case of Kicksecure, att time of writing, Kicksecure uses Network Manager by default.

https://wiki.debian.org/NetworkManager

The networking related default installed packages are defined in this file: kicksecure-network-conf/debian/control at master · Kicksecure/kicksecure-network-conf · GitHub

Package kicksecure-network-conf contains Kicksecure’s network related configurations.

Kicksecure at the time of writing does not install ifupdown by default. Therefore that files does not exist and creating it does nothing.

This would be if using ifupdown with systemd.

This would be if using ifupdown with sysvinit.

A Debian specific (?) wrapper that works for both, sysvinit and systemd.

However, since Kicksecure at time of writing uses Network Manager the command would be:

sudo service NetworkManager restart

Also using the Network Manager systray apples and/or using nmcli on the command line might be helpful.