Hardware detection problems: CD-ROM (special device /dev/sr0 does not exist) and HP LaserJet 4 printer (hplip does not detect)

Computer: Lenovo Thinkpad T500
OS: Kicksecure (distromorph)(latest version)
DE: Xfce
Printer: HP LaserJet 4
CD Drive: Thinkpad Ultrabay

I have a laptop on which I recently re-installed the Kicksecure. It is a distromorph from a fresh re-installation of the latest version of Debian.
I have never been able to get the DVD/CD-RW drive to work. When I insert a CD or DVD, I hear the drive whirring, but nothing pops up on the desktop. If I type ‘sudo thunar’ into the terminal, I am able to see the drive in the sidebar, but if I try to mount it, it tells me the following:

Failed to mount “cdrom0”.
mount: /media/cdrom0: special device /dev/sr0 does not exist.

Before morphing this installation, I tested a CD to make sure the drive was functional. On Debian, the CD popped up on the desktop and I was about to mount the drive. It seems to be the morph into Kicksecure which causes the problem. As a security-focused distro, I assume it is intentional.

A similar problem occurs with my printer. It is an HP LaserJet 4, a printer known for its GNU/Linux-friendliness. As it uses a parallel port, I used a parallel-to-USB adapter I had lying around the house. I read somewhere that some units use blobs, so I also bought a parallel-to USB adapter from ThinkPenguin which does not use proprietary firmware blobs, so I don’t believe it contributes to the problem. I installed hp-lip and attemtped to set-up the printer, but the discovery tool doesn’t detect it. Here is what I have done so far:

-I tested both adapters. Nothing.
-I checked dmesg to see if the printer appears. I don’t see anything in particular which looks like something has been plugged in. Could it be because it’s a parallel-to-USB connection instead of a regular USB device? I have no other parallel devices to test.
-I restarted the computer with the printer plugged in and turned on and checked dmesg again as well as running hp-setup. Still nothing.

I was unable to test the printer on Debian before the morph, but I wanted to know if anyone has had a similar problem. Post-morph, other USB devices such as external HDDs, USB drives, and a webcam work with no issue. The only other USB device which has trouble with recognition…is an external CD drive. I assume the permissions for external and internal CD drives are the same, so it traces its roots to the first problem.

Before posting, I had a look through the docs under the following pages which I thought might give me clues:

-Printing and Scanning (page returned blank)
-System Configuration and Access
-Advanced Host Security
-Operating System Hardening
-Protection Against Physical Attacks
-Full Disk Encryption
-Malware, Computer Viruses, Firmware Trojans and Antivirus Scanners

I tried these search terms:

failed to mount cdrom0 mount: /media/cdrom0: special device /dev/sr0 does not exist error debian
failed to mount cdrom0 mount: /media/cdrom0: special device /dev/sr0 does not exist error kicksecure
cdrom0 error kicksecure
cdrom0 error debian
sr0 does not exist kicksecure
sr0 does not exist debian

hplip debian laserjet 4
hplip kicksecure laserjet 4
hp-setup kicksecure
hp-setup debian
hp laserjet 4 no recognition dmesg
hp laserjet 4 no discovery hplip usb

For the CD-ROM:
After killing the CSS on this page, I followed the instructions verbatim. I still returned the original error in bash after completing them. Perhaps it’s because RHEL differs in its notation than Debian? If so, how do I modify it?
https :// www . ibm . com/support/pages/linux-error-mount-special-device-devcdrom-does-not-exist-cd-rom-drive-ibm-eserver-bladecenter

This page did not load for me. I suspect Cloudflare usage, as I’m on Tor Browser with Javascript disabled.
https :// www . linuxquestions . org /questions/linux-hardware-18/mount-special-device-dev-cdrom-does-not-exist-21369/

Same error as before:
https :// linuxconfig . org /how-to-mount-cdrom-in-linux

For the Printer:
https :// packages.debian .org/ bullseye/hplip
https :// www.openprinting .org/ printer/HP/HP-LaserJet_4
https :// developers.hp .com/ hp-linux-imaging-and-printing/KnowledgeBase/Troubleshooting/BasicHPLIPTroubleshooting
https :// bbs.archlinux .org/ viewtopic.php?id=103283
https :// askubuntu .com/ questions/1247245/hp-laser-jet-4-plus-printer (my printer is not the Plus, but I had a look. I get ‘command not found’ for lpinfo -v)

The package page suggests USB support, but nothing about parallel or parallel-to-USB. Neither does the other page. Few people seem to have problems with the LaserJet4 in Debian.
Most pages I saw were problems with printing output rather than with the printer itself. I’m unsure of what to do.

Thank you for reading my post. I appreciate your time. If you need any more information from me, please let me know.