Lost operability after update

hello all,

A bit of a tech dumbass as the name indicates, so apologies for not knowing basics. Am a journo trying to learn more a secure OS.

Installing KS Debian XFCE took about a week trying all sorts of suggestions and still not got both modules running properly. But for now my latest update attempts appear to have borked my installation.

Was running Debian 11 bullseye
did a sudo apt update + upgrade
came back to desktop to find mouse frozen.
rebooted, twice, thrice and mouse worked for awhile.
at one stage, not even the Kicksecure home page loaded properly i.e. links not clickable.

Now showing Debian 12 but functionality comes and goes.
For example, Synaptic is no longer loadable from menu, only terminal. Sometimes it disappears between alt-tab programme switching.
No matter what terminal commands I try, however, terminal output always ends with same eight (now nine) errors:

Errors were encountered while processing:
linux-headers-6.1.0-11-amd64
linux-image-6.1.0-11-amd64
linux-headers-amd64
linux-image-amd64
tirdad-dkms
tirdad
kicksecure-cli-host-packages-recommended
kicksecure-cli-host
kicksecure-xfce-host

Full terminal output

Have spent days on trying to solve this and searched literally dozens of help pages, forums, and note that there is not one result for [kicksecure] on the recommended stack exchange page, so am trying here as it seems more active.

Trying not to take valuable time and have read Posting links for new users

Some of the other things I’ve seen over the last few days:

General notes on experience

  • Right click not working on desktop or anywhere else, including programmes eg Librewrite.

  • Ctrl-v not working.

  • Host OS Kicksecure start button not responding to clicks, can still access programmes via alt-f3

  • VB opens but VM whonix gateway not working: No response to clicks on VM start, settings, or VB screen maximisation/minimasation

  • Can open but not close functions in LibreWrite, eg can open and run spell check but spell check does not respond to x (top-right) box click, not able to tab to (bottom right) x close box. Have to restart LibreWrite to close Spellcheck.

  • Librewrite select-all works via ctrl+A, but clicking on the selected text box does not enable editing, only pressing the keyboard down arrow releases the selection for editing.

  • Cannot click already-open programmes via top toolbar tabs, can only switch between open programmes via alt+tab on keyboard.

  • About XFCE tab opens, but close button does not work. Red upper-right close x does work.

Tried removing and reinstalling VirtualBox but still same problems.

Overall, like others moving to Debian 12, the system now seems to have settled down from the above experiences. But am unable to remove programmes I’ve installed via Synaptic eg Signal, due to above errors.

Sorry for long post, and any advice grovelling welcome.

NOT A NINJA

. . .

ps: Among the many commands tried was this one:

/usr/bin/deborphan: The status file is in an improper state.
One or more packages are marked as half-installed, half-configured,
unpacked, triggers-awaited or triggers-pending. Exiting.

Note: dpkg --audit may be used to find such packages.

/usr/bin/deborphan: The status file is in an improper state.
One or more packages are marked as half-installed, half-configured,
unpacked, triggers-awaited or triggers-pending.

Freezing issue… Low RAM issue?
Troubleshooting, Low RAM Issues

Way too many issues for 1 forum thread. Please see:
Free Support for Kicksecure ™ chapter General Advice in Kicksecure wiki

You do not need to limit your search to Kicksecure. All of these issues don’t seem specific to Kicksecure. Widen your search to include Debian.

[user ~]% nonroot-uprade
[user ~]% sudo upgra

These commands simply do not exist and are not mentioned in any documentation. The upgrade documentation is here:

Consult /var/lib/dkms/8188eu/1.2/build/make.log for more information.

This is an error being discussed all over the internet.

You most likely need to do what’s being said there.

Don’t see these messages as a giant unified blob of gibberish. Try to read it line by line. Search for understandable hints. And then act accordingly. But in this case…

[user ~]% sudo apt autoremove

kbuild libgsoap-2.8.124 liblzf1 libtpms0 libvncserver1 module-assistant

I don’t think you can do this.

You’re using a kernel module 8188eu. Probably a proprietary wifi driver. As long that is installed, you cannot remove packages such as module-assistant or kbuild I would assume.

Which package owns file /var/lib/dkms/8188eu/1.2/source/dkms.conf? Please check and enlighten me. To check:

dpkg -S /var/lib/dkms/8188eu/1.2/source/dkms.conf

I couldn’t find that file with a site:debian.org or genral search query.

If you search for

"/var/lib/dkms/8188eu"

there are even more issues.

Needless to say, not a software package that I maintain.

Might be this bug:

That package should be uninstalled.

Debian might support your wifi device by installing package firmware-realtek.

sudo apt install firmware-realtek

But only needed in case wifi functionality is missing.

1 Like

Huh, neither could this computer:
dpkg-query: no path found matching pattern /var/lib/dkms/8188eu/1.2/source/dkms.conf

Apologies for numerous issues, I was including them all because I was going in circles after trying many supposed solutions, including from Debian pages. As noted, Stackexchange has no entries for Kicksecure, and while some are indeed gibberish, I have tried literally dozens of recommended fixes, none of which worked.

Pretty sure I picked non-proprietary drivers at install because that’s kinda the whole point of open-source systems, innit? But most grateful for your pointers. Will try to stick to one issue per post in future, after I try to more fully understand differences between the Kicksecure layer(?) and Debian host.

Actually expected. Seems to be auto generated files. Even files happening for files related to proper Debian packages. Another idea to identify the package it’s coming from:

dpkg -l | grep 8188

Did you install something aircrack-ng related? Most hints are pointing at it. And that thing is my top suspect which has broken the package management.

Just a follow up issue.

Running

sudo dpkg --audit

is a good idea anyhow.

A since Kicksecure specific issues are rare by comparison, there’s no need for it.

I still don’t know where this 8188eu is coming from. That package could have a bug. And by looking at how long Build error for 6.1 kernel version · Issue #224 · aircrack-ng/rtl8188eus · GitHub stays unfixed, I’d not use that software either.

So to able to run autoremove while keeping that package, you’d need to mark module-assistant kbuild as manually installed.

sudo apt install module-assistant kbuild

That is probably a packaging bug of above package.

But since that package fails to compile the kernel module and isn’t easy to fix (unless you follow that bug discussion) I recommend to get rid of it. That should then also fix apt autoremove.

“Debian issues” if installing broken software from third-party repositories.

1 Like

Ahhhhh yes, only just remembered I tried to install the drivers for a TPLink USB wifi stick - which failed - and I had forgotten all about it among a hundred other things. USB tethering my phone’s wifi connection worked straight out of the box.

My apologies for taking up your valuable time,
and many thanks for all the tips.